Sauerleague - Ogros

#ogros @ irc.gamesurge.net

 

Today we updated our Mumble server to the 1.2 series.

You need a Mumble 1.2.x compatible client to

...


Sauerleague.org 2008-2017